aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2016-01-20 16:56:34 +0100
committerHarald Welte <laforge@gnumonks.org>2016-02-15 14:26:51 +0100
commit29a0197ead937c713a3b8e8339d2a3974ac6f0c9 (patch)
treec8c732ddb5ecb08ac5ce5aac7ac73cc2b4f98b4d /configure.ac
parentccc7a1bf46d05a2b910b0b995e99e3e1f28f1fae (diff)
LC15: configure.ac: Allow specifying an alternate include-dir
The user can now use ./configure --with-litecell15=/my/local/path
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 66879d95..0951e187 100644
--- a/configure.ac
+++ b/configure.ac
@@ -73,8 +73,19 @@ AC_ARG_ENABLE(litecell15,
AC_HELP_STRING([--enable-litecell15],
[enable code for NuRAN Wireless Litecell15 bts [default=no]]),
[enable_litecell15="yes"],[enable_litecell15="no"])
+AC_ARG_WITH([litecell15], [AS_HELP_STRING([--with-litecell15=INCLUDE_DIR], [Location of the litecell 1.5 API header files])],
+ [litecell15_incdir="$withval"],[litecell15_incdir="$incdir"])
+AC_SUBST([LITECELL15_INCDIR], $litecell15_incdir)
AC_MSG_RESULT([$enable_litecell15])
AM_CONDITIONAL(ENABLE_LC15BTS, test "x$enable_litecell15" = "xyes")
+if test "$enable_litecell15" = "yes"; then
+ oldCPPFLAGS=$CPPFLAGS
+ CPPFLAGS="$CPPFLAGS -I$LITECELL15_INCDIR -I$srcdir/include $LIBOSMOCORE_CFLAGS"
+ AC_CHECK_HEADER([nrw/litecell15/litecell15.h],[],
+ [AC_MSG_ERROR([nrw/litecell15/litecell15.h can not be found in $litecell15_incdir])],
+ [#include <nrw/litecell15/litecell15.h>])
+ CPPFLAGS=$oldCPPFLAGS
+fi
# We share gsm_data.h with OpenBSC and need to be pointed to the source
# directory of OpenBSC for now.