aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorYves Godin <support@nuranwireless.com>2015-11-12 08:32:07 -0500
committerHarald Welte <laforge@gnumonks.org>2016-02-15 14:26:33 +0100
commit2a711887b7e91893555891e5c033189d6705eec3 (patch)
tree00abee90a3e8d04f01f34df54f7d7f1c3494fd50 /configure.ac
parent5a945dad0cb34dc351427b33a3ce0ed9dd0e394f (diff)
LC15: Add initial support for the NuRAN Wireless Litecell 1.5
This commit adds basic support for the Litecell 1.5. Multi-TRX is not supported yet. Instead, multiple instances of the BTS can be launched using command line parameter -n <HW_TRX_NR> to specify if TRX 1 or 2 must be used by the bts. Note that only TRX 1 opens a connection to the PCU. Full support for GPRS on both TRX will come at the same time than the multi-TRX support. The BTS manager has been adapted to match the new hardware but otherwise it has not been improved or changed compared to the one used on the SuperFemto/Litecell (sysmobts).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8239c122..d16a5ee7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -68,6 +68,14 @@ if test "$enable_octphy" = "yes" ; then
CPPFLAGS=$oldCPPFLAGS
fi
+AC_MSG_CHECKING([whether to enable NuRAN Wireless Litecell 1.5 hardware support])
+AC_ARG_ENABLE(litecell15-bts,
+ AC_HELP_STRING([--enable-litecell15-bts],
+ [enable code for NuRAN Wireless Litecell15 bts [default=no]]),
+ [enable_litecell15_bts="yes"],[enable_litecell15_bts="no"])
+AC_MSG_RESULT([$enable_litecell15_bts])
+AM_CONDITIONAL(ENABLE_LC15BTS, test "x$enable_litecell15_bts" = "xyes")
+
# We share gsm_data.h with OpenBSC and need to be pointed to the source
# directory of OpenBSC for now.
AC_ARG_WITH([openbsc],
@@ -101,6 +109,7 @@ AC_OUTPUT(
src/Makefile
src/common/Makefile
src/osmo-bts-sysmo/Makefile
+ src/osmo-bts-litecell15/Makefile
src/osmo-bts-trx/Makefile
src/osmo-bts-octphy/Makefile
include/Makefile