aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPhilipp Maier <pmaier@sysmocom.de>2018-03-23 17:12:18 +0100
committerHarald Welte <laforge@gnumonks.org>2018-04-09 08:29:20 +0000
commitdd4a6518f2118775c12affc02ac1e0dcc848d89a (patch)
treee3c3d579d47e0135b3be0e646e7b2da993094a5c /configure.ac
parente5518b07d6fc3375a9e4004a2ed2680dbb2d178e (diff)
octphy: integrate octasics latest header release
At the moment osmo-bts does not compile with the latest header file release from OCTSDR-2G-02.10.00-B1837-ALPHA as there are struct members removed and new ones added. The changes do not affect actual functionality in the existing code. The only affected parts are vty functions that query status information about the clock sync manager. - Add detection logic in configure.ac to detect if the affected struct members are present - Add conditional compiling to handle the different combinations of available struct members. Change-Id: Ic38d8dc35522205c4ffab583b4e61b5ef03cdba2 Related: SYS#4139 Patch-by: Octasic inc.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac84
1 files changed, 77 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 1d7379f1..9767349a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -152,13 +152,6 @@ if test "$enable_octphy" = "yes" ; then
[],
[#include <octphy/octvc1/hw/octvc1_hw_api.h>])
- AC_CHECK_MEMBER([tOCTVC1_HW_MSG_CLOCK_SYNC_MGR_STATS_RSP.ulSyncLossCnt],
- AC_DEFINE([OCTPHY_USE_SYNC_LOSS_CNT],
- [1],
- [Define to 1 if your octphy header files renamed ulSyncLosseCnt to ulSyncLossCnt]),
- [],
- [#include <octphy/octvc1/hw/octvc1_hw_api.h>])
-
AC_CHECK_MEMBER([tOCTVC1_HW_MSG_RF_PORT_INFO_ANTENNA_TX_CONFIG_RSP.TxConfig],
AC_DEFINE([OCTPHY_USE_TX_CONFIG],
[1],
@@ -180,6 +173,83 @@ if test "$enable_octphy" = "yes" ; then
[],
[#include <octphy/octvc1/gsm/octvc1_gsm_api.h>])
+ AC_CHECK_MEMBER([tOCTVC1_HW_MSG_CLOCK_SYNC_MGR_INFO_RSP.ulClkSourceSelection],
+ AC_DEFINE([OCTPHY_USE_CLK_SOURCE_SELECTION],
+ [1],
+ [Define to 1 if your octphy header files supports ulClkSourceSelection in tOCTVC1_HW_MSG_CLOCK_SYNC_MGR_INFO_RSP]),
+ [],
+ [#include <octphy/octvc1/hw/octvc1_hw_api.h>])
+
+ AC_CHECK_MEMBER([tOCTVC1_HW_MSG_CLOCK_SYNC_MGR_STATS_RSP.lClockError],
+ AC_DEFINE([OCTPHY_USE_CLOCK_SYNC_MGR_STATS_CLOCK_ERROR],
+ [1],
+ [Define to 1 if your octphy header files supports lClockError in tOCTVC1_HW_MSG_CLOCK_SYNC_MGR_STATS_RSP]),
+ [],
+ [#include <octphy/octvc1/hw/octvc1_hw_api.h>])
+
+ AC_CHECK_MEMBER([tOCTVC1_HW_MSG_CLOCK_SYNC_MGR_STATS_RSP.lDroppedCycles],
+ AC_DEFINE([OCTPHY_USE_CLOCK_SYNC_MGR_STATS_DROPPED_CYCLES],
+ [1],
+ [Define to 1 if your octphy header files supports lDroppedCycles in tOCTVC1_HW_MSG_CLOCK_SYNC_MGR_STATS_RSP]),
+ [],
+ [#include <octphy/octvc1/hw/octvc1_hw_api.h>])
+
+ AC_CHECK_MEMBER([tOCTVC1_HW_MSG_CLOCK_SYNC_MGR_STATS_RSP.ulPllFreqHz],
+ AC_DEFINE([OCTPHY_USE_CLOCK_SYNC_MGR_STATS_PLL_FREQ_HZ],
+ [1],
+ [Define to 1 if your octphy header files supports ulPllFreqHz in tOCTVC1_HW_MSG_CLOCK_SYNC_MGR_STATS_RSP]),
+ [],
+ [#include <octphy/octvc1/hw/octvc1_hw_api.h>])
+
+ AC_CHECK_MEMBER([tOCTVC1_HW_MSG_CLOCK_SYNC_MGR_STATS_RSP.ulPllFractionalFreqHz],
+ AC_DEFINE([OCTPHY_USE_CLOCK_SYNC_MGR_STATS_PLL_FRACTIONAL_FREQ_HZ],
+ [1],
+ [Define to 1 if your octphy header files supports ulPllFractionalFreqHz in tOCTVC1_HW_MSG_CLOCK_SYNC_MGR_STATS_RSP]),
+ [],
+ [#include <octphy/octvc1/hw/octvc1_hw_api.h>])
+
+ AC_CHECK_MEMBER([tOCTVC1_HW_MSG_CLOCK_SYNC_MGR_STATS_RSP.ulSlipCnt],
+ AC_DEFINE([OCTPHY_USE_CLOCK_SYNC_MGR_STATS_SLIP_CNT],
+ [1],
+ [Define to 1 if your octphy header files supports ulSlipCnt in tOCTVC1_HW_MSG_CLOCK_SYNC_MGR_STATS_RSP]),
+ [],
+ [#include <octphy/octvc1/hw/octvc1_hw_api.h>])
+
+ AC_CHECK_MEMBER([tOCTVC1_HW_MSG_CLOCK_SYNC_MGR_STATS_RSP.ulSyncLosseCnt],
+ AC_DEFINE([OCTPHY_USE_CLOCK_SYNC_MGR_STATS_SYNC_LOSSE_CNT],
+ [1],
+ [Define to 1 if your octphy header files supports ulSyncLosseCnt in tOCTVC1_HW_MSG_CLOCK_SYNC_MGR_STATS_RSP]),
+ [],
+ [#include <octphy/octvc1/hw/octvc1_hw_api.h>])
+
+ AC_CHECK_MEMBER([tOCTVC1_HW_MSG_CLOCK_SYNC_MGR_STATS_RSP.ulSyncLossCnt],
+ AC_DEFINE([OCTPHY_USE_CLOCK_SYNC_MGR_STATS_SYNC_LOSS_CNT],
+ [1],
+ [Define to 1 if your octphy header files supports ulSyncLossCnt in tOCTVC1_HW_MSG_CLOCK_SYNC_MGR_STATS_RSP]),
+ [],
+ [#include <octphy/octvc1/hw/octvc1_hw_api.h>])
+
+ AC_CHECK_MEMBER([tOCTVC1_HW_MSG_CLOCK_SYNC_MGR_STATS_RSP.ulSourceState],
+ AC_DEFINE([OCTPHY_USE_CLOCK_SYNC_MGR_STATS_SOURCE_STATE],
+ [1],
+ [Define to 1 if your octphy header files supports ulSourceState in tOCTVC1_HW_MSG_CLOCK_SYNC_MGR_STATS_RSP]),
+ [],
+ [#include <octphy/octvc1/hw/octvc1_hw_api.h>])
+
+ AC_CHECK_MEMBER([tOCTVC1_HW_MSG_CLOCK_SYNC_MGR_STATS_RSP.ulDacState],
+ AC_DEFINE([OCTPHY_USE_CLOCK_SYNC_MGR_STATS_DAC_STATE],
+ [1],
+ [Define to 1 if your octphy header files supports ulDacState in tOCTVC1_HW_MSG_CLOCK_SYNC_MGR_STATS_RSP]),
+ [],
+ [#include <octphy/octvc1/hw/octvc1_hw_api.h>])
+
+ AC_CHECK_MEMBER([tOCTVC1_HW_MSG_CLOCK_SYNC_MGR_STATS_RSP.ulDriftElapseTimeUs],
+ AC_DEFINE([OCTPHY_USE_CLOCK_SYNC_MGR_STATS_DRIFT_ELAPSE_TIME_US],
+ [1],
+ [Define to 1 if your octphy header files supports ulDriftElapseTimeUs in tOCTVC1_HW_MSG_CLOCK_SYNC_MGR_STATS_RSP]),
+ [],
+ [#include <octphy/octvc1/hw/octvc1_hw_api.h>])
+
CPPFLAGS=$oldCPPFLAGS
fi