aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax <msuraev@sysmocom.de>2018-01-21 22:50:10 +0100
committerMax <msuraev@sysmocom.de>2018-01-21 22:50:10 +0100
commitf5a810d6f789b88504f9ef972e96c45cce459d62 (patch)
tree8c2b0ff36a42d475cc958f7b15eb4e3126fdfe56 /configure.ac
parente95ad79d6c236489069f769c6b9c3cfc1aca595a (diff)
Remove unneeded LIBOSMOCORE_CFLAGS from tests
When testing for the presence of particular BTS model-specific header during ./configure step, we don't need to add LIBOSMOCORE_CFLAGS because none of those headers use it for compilation. Moreover, adding it might hide the problem if the headers under check are available in the same location where libosmocore headers were checked out. Change-Id: I64bf1acb9db999567e8a2a6690cfc96d6e4b7ee1
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 88751f44..8c6a7f85 100644
--- a/configure.ac
+++ b/configure.ac
@@ -110,7 +110,7 @@ AC_MSG_RESULT([$enable_octphy])
AM_CONDITIONAL(ENABLE_OCTPHY, test "x$enable_octphy" = "xyes")
if test "$enable_octphy" = "yes" ; then
oldCPPFLAGS=$CPPFLAGS
- CPPFLAGS="$CPPFLAGS -I$OCTSDR2G_INCDIR -I$srcdir/include $LIBOSMOCORE_CFLAGS"
+ CPPFLAGS="$CPPFLAGS -I$OCTSDR2G_INCDIR -I$srcdir/include"
AC_CHECK_HEADER([octphy/octvc1/gsm/octvc1_gsm_default.h],[],
[AC_MSG_ERROR([octphy/octvc1/gsm/octvc1_gsm_default.h can not be found in $octsdr2g_incdir])],
@@ -173,7 +173,7 @@ AC_MSG_RESULT([$enable_litecell15])
AM_CONDITIONAL(ENABLE_LC15BTS, test "x$enable_litecell15" = "xyes")
if test "$enable_litecell15" = "yes"; then
oldCPPFLAGS=$CPPFLAGS
- CPPFLAGS="$CPPFLAGS -I$LITECELL15_INCDIR -I$srcdir/include $LIBOSMOCORE_CFLAGS"
+ CPPFLAGS="$CPPFLAGS -I$LITECELL15_INCDIR -I$srcdir/include"
AC_CHECK_HEADER([nrw/litecell15/litecell15.h],[],
[AC_MSG_ERROR([nrw/litecell15/litecell15.h can not be found in $litecell15_incdir])],
[#include <nrw/litecell15/litecell15.h>])
@@ -183,7 +183,7 @@ fi
# Check for the sbts2050_header.h that was added after the 3.6 release
oldCPPFLAGS=$CPPFLAGS
-CPPFLAGS="$CPPFLAGS $LIBOSMOCORE_CFLAGS"
+CPPFLAGS="$CPPFLAGS"
AC_CHECK_HEADER([sysmocom/femtobts/sbts2050_header.h],
[sysmo_uc_header="yes"],[])
CPPFLAGS=$oldCPPFLAGS