aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPhilipp Maier <pmaier@sysmocom.de>2018-06-21 16:28:47 +0200
committerPhilipp Maier <pmaier@sysmocom.de>2018-06-28 16:12:25 +0200
commit685ded192907a24e2e97c9ae42fd2746b49bb587 (patch)
tree7166200ec24f65e0b88574696a994eeaed655bfb /configure.ac
parent0257f52835c4acb16c70c524ee5fc177e5492856 (diff)
octphy: add support for 16x oversampling mode
The latest octphy firmware release (octsdr-2g-02.11.00-B1927-alpha), introduces a 16X oversampling option which is not yet supported in osmo-bts. - Add oversampling flag in phy_link.h - Add VTY commands to enable/disable oversampling - Add phy messages to enable/disable oversampling - Add conditional compilation to preserve support for legacy header files and firmware Change-Id: Ib78f92bfe03ff20aa0a257763c90844fb7b87cf0 Related: SYS#4257 Patch-by: Octasic inc.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6456f8ab..b364e4df 100644
--- a/configure.ac
+++ b/configure.ac
@@ -250,6 +250,13 @@ if test "$enable_octphy" = "yes" ; then
[],
[#include <octphy/octvc1/hw/octvc1_hw_api.h>])
+ AC_CHECK_MEMBER([tOCTVC1_GSM_MSG_OVERSAMPLE_SELECT_16X_MODIFY_CMD.ulOversample16xEnableFlag],
+ AC_DEFINE([OCTPHY_USE_16X_OVERSAMPLING],
+ [1],
+ [Define to 1 if your octphy header files support 16x oversampling]),
+ [],
+ [#include <octphy/octvc1/gsm/octvc1_gsm_api.h>])
+
CPPFLAGS=$oldCPPFLAGS
fi