aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPhilipp Maier <pmaier@sysmocom.de>2017-03-06 13:52:56 +0100
committerPhilipp Maier <pmaier@sysmocom.de>2017-04-13 19:08:47 +0200
commit25742a5929edecc545a4fc254f678cc834f8c3b3 (patch)
tree65bef9c4fa2e7ef0fb1ef4ba4310fbf132e8042e /configure.ac
parente4403464ed7de23f8fa3a2a57acee31248993c3d (diff)
octphy: set tx/rx antenne IDs via VTY
add support for the TX/RX antenna-id feature that has been introduced with release OCTSDR-2G-02.07.00-B1314-BETA. The user can now set individual ID numbers for the TX and for the RX antenna. Change-Id: I872fe3c4d7b593358a4ce2f02cf0726611b9f3aa
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index cbfbf125..a03b2dd1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -112,6 +112,13 @@ if test "$enable_octphy" = "yes" ; then
[],
[#include <octphy/octvc1/hw/octvc1_hw_api.h>])
+ AC_CHECK_MEMBER([tOCTVC1_GSM_RF_CONFIG.ulTxAntennaId],
+ AC_DEFINE([OCTPHY_USE_ANTENNA_ID],
+ [1],
+ [Define to 1 if your octphy header files support antenna ids in tOCTVC1_GSM_RF_CONFIG]),
+ [],
+ [#include <octphy/octvc1/gsm/octvc1_gsm_api.h>])
+
CPPFLAGS=$oldCPPFLAGS
fi