aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2017-10-27 22:53:43 +0200
committerHarald Welte <laforge@gnumonks.org>2017-10-27 22:53:43 +0200
commit2757cbc2a8375560c2cf5d20978c3c7c74bf5546 (patch)
treeed5fb334a37596b9c5d174b14aca433967c32bc2
parent9982b95069c58a3cb9b97bb6bc75932db81886ad (diff)
update dependencies to latest libosmo-*
We can either try to really build with those old versions or find the minimum version, or we can simply require latest version of all libosmo*, which is the safeest choice for now. Change-Id: I08915540b92d5135b0c325e30b5b6e24f88e6282
-rw-r--r--configure.ac14
1 files changed, 7 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index bda30b5..80f1afd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -35,14 +35,14 @@ AC_HEADER_STDC
dnl Checks for typedefs, structures and compiler characteristics
dnl checks for libraries
-PKG_CHECK_MODULES(LIBOSMOCORE, libosmocore >= 0.3.9)
-PKG_CHECK_MODULES(LIBOSMOVTY, libosmovty)
+PKG_CHECK_MODULES(LIBOSMOCORE, libosmocore >= 0.10.0)
+PKG_CHECK_MODULES(LIBOSMOVTY, libosmovty >= 0.10.0)
PKG_CHECK_MODULES(LIBOSMOTRAU, libosmotrau >= 0.3.2)
-PKG_CHECK_MODULES(LIBOSMOGSM, libosmogsm >= 0.3.3)
-PKG_CHECK_MODULES(LIBOSMOCTRL, libosmoctrl)
-PKG_CHECK_MODULES(LIBOSMOABIS, libosmoabis)
-PKG_CHECK_MODULES(LIBOSMOCODEC, libosmocodec)
-PKG_CHECK_MODULES(LIBOSMOCODING, libosmocoding)
+PKG_CHECK_MODULES(LIBOSMOGSM, libosmogsm >= 0.10.0)
+PKG_CHECK_MODULES(LIBOSMOCTRL, libosmoctrl >= 0.10.0)
+PKG_CHECK_MODULES(LIBOSMOABIS, libosmoabis >= 0.3.2)
+PKG_CHECK_MODULES(LIBOSMOCODEC, libosmocodec >= 0.10.0)
+PKG_CHECK_MODULES(LIBOSMOCODING, libosmocoding >= 0.10.0)
PKG_CHECK_MODULES(ORTP, ortp)
AC_MSG_CHECKING([whether to enable support for sysmoBTS L1/PHY support])