aboutsummaryrefslogtreecommitdiffstats
path: root/src/utils/Makefile.am
diff options
context:
space:
mode:
authorPau Espin Pedrol <pespin@sysmocom.de>2020-07-16 15:26:10 +0200
committerlaforge <laforge@osmocom.org>2020-07-18 21:45:32 +0000
commitbd5b92fa7db18fd94d72030332312a5eda5ef89a (patch)
treef17d70046e46e137c4d8159f639d7bb68a75967a /src/utils/Makefile.am
parent8d4f94a176094e6ca53c3cd48658007ac3e007de (diff)
Move acc_ramp_init inside gsm_bts_alloc
The function initializes the struct owned by a bts, so it makes sense to have it done there instead of somewhere else later. It was most probably put in bsc_vty when it was initially introduced because of all the data structure and object file mess I untangled during last set of patches. Change-Id: I66c4b208583e92070793183b83b3a7b7edf6ba00
Diffstat (limited to 'src/utils/Makefile.am')
-rw-r--r--src/utils/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/utils/Makefile.am b/src/utils/Makefile.am
index 653ed97bf..683c227ef 100644
--- a/src/utils/Makefile.am
+++ b/src/utils/Makefile.am
@@ -48,6 +48,7 @@ bs11_config_SOURCES = \
bs11_config_LDADD = \
$(top_builddir)/src/osmo-bsc/abis_nm.o \
+ $(top_builddir)/src/osmo-bsc/acc_ramp.o \
$(top_builddir)/src/osmo-bsc/bts.o \
$(top_builddir)/src/osmo-bsc/bts_trx.o \
$(top_builddir)/src/osmo-bsc/bts_siemens_bs11.o \
@@ -120,6 +121,7 @@ meas_json_SOURCES = \
meas_json_LDADD = \
$(top_builddir)/src/osmo-bsc/abis_nm.o \
+ $(top_builddir)/src/osmo-bsc/acc_ramp.o \
$(top_builddir)/src/osmo-bsc/bts.o \
$(top_builddir)/src/osmo-bsc/bts_trx.o \
$(top_builddir)/src/osmo-bsc/gsm_data.o \