aboutsummaryrefslogtreecommitdiffstats
path: root/src/osmo-bsc_nat/Makefile.am
diff options
context:
space:
mode:
authorNeels Hofmeyr <nhofmeyr@sysmocom.de>2017-07-19 16:48:42 +0200
committerNeels Hofmeyr <neels@hofmeyr.de>2017-08-30 14:09:31 +0200
commitbecfc4cb1ba9d759915a5b430aedc0d29c67858b (patch)
tree5dcf6925ed39c2433571f3718e8350e9e69b47f0 /src/osmo-bsc_nat/Makefile.am
parentc4c794c6c735b63ba3b5021e016d4296ef601cca (diff)
move to osmo-mgw.git: osmo-bsc_mgcp and libmgcp as libosmo-legacy-mgcp
Rewire build and includes to libosmo-legacy-mgcp. Drop osmo-bsc_mgcp and related python tests, now found in osmo-mgw.git. libosmo-legacy-mgcp is installed from osmo-mgw, hence add the dependency to jenkins.sh (so far using the pre_release branch). Change-Id: Ic99d681759edce11564da62500c2aac5cf5fffe2
Diffstat (limited to 'src/osmo-bsc_nat/Makefile.am')
-rw-r--r--src/osmo-bsc_nat/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/osmo-bsc_nat/Makefile.am b/src/osmo-bsc_nat/Makefile.am
index b7c13ad3e..1eec7aa1c 100644
--- a/src/osmo-bsc_nat/Makefile.am
+++ b/src/osmo-bsc_nat/Makefile.am
@@ -13,6 +13,7 @@ AM_CFLAGS = \
$(LIBOSMOSCCP_CFLAGS) \
$(LIBOSMOABIS_CFLAGS) \
$(LIBOSMONETIF_CFLAGS) \
+ $(LIBOSMOLEGACYMGCP_CFLAGS) \
$(LIBCRYPTO_CFLAGS) \
$(COVERAGE_CFLAGS) \
$(NULL)
@@ -40,7 +41,6 @@ osmo_bsc_nat_SOURCES = \
$(NULL)
osmo_bsc_nat_LDADD = \
- $(top_builddir)/src/libmgcp/libmgcp.a \
$(top_builddir)/src/libfilter/libfilter.a \
$(top_builddir)/src/libbsc/libbsc.a \
$(top_builddir)/src/libcommon-cs/libcommon-cs.a \
@@ -54,6 +54,8 @@ osmo_bsc_nat_LDADD = \
$(LIBOSMOABIS_LIBS) \
$(LIBOSMONETIF_LIBS) \
$(LIBOSMOSIGTRAN_LIBS) \
+ $(LIBOSMOLEGACYMGCP_LIBS) \
$(LIBCRYPTO_LIBS) \
+ $(LIBRARY_GSM) \
-lrt \
$(NULL)