aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/tests/gprs/Makefile.am
diff options
context:
space:
mode:
authorJacob Erlbeck <jerlbeck@sysmocom.de>2014-12-11 16:54:14 +0100
committerHolger Hans Peter Freyther <holger@moiji-mobile.com>2015-01-10 21:26:18 +0100
commitf3a271fa73ea58a628a51aa310e1da20a5526f31 (patch)
tree94c8b849e641080324a2c878ca93ee8695fbae3d /openbsc/tests/gprs/Makefile.am
parent46684dcfd2d0aadcf63f9493d0d84afe467c7193 (diff)
gprs: Add encoder/decoder for the Subscriber Update Protocol
This patch adds functions to encode and decode GSUP messages. This does not include the layer 1 framing (IPA). The messages so far supported are: send_auth_info_*, update_location_*, location_cancellation_*. Sponsored-by: On-Waves ehf
Diffstat (limited to 'openbsc/tests/gprs/Makefile.am')
-rw-r--r--openbsc/tests/gprs/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/openbsc/tests/gprs/Makefile.am b/openbsc/tests/gprs/Makefile.am
index 193655fa4..616042b8a 100644
--- a/openbsc/tests/gprs/Makefile.am
+++ b/openbsc/tests/gprs/Makefile.am
@@ -5,5 +5,7 @@ EXTRA_DIST = gprs_test.ok
noinst_PROGRAMS = gprs_test
-gprs_test_SOURCES = gprs_test.c $(top_srcdir)/src/gprs/gprs_utils.c
-gprs_test_LDADD = $(LIBOSMOCORE_LIBS)
+gprs_test_SOURCES = gprs_test.c $(top_srcdir)/src/gprs/gprs_utils.c \
+ $(top_srcdir)/src/gprs/gprs_gsup_messages.c
+
+gprs_test_LDADD = $(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS)