aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/src/osmo-bsc/Makefile.am
diff options
context:
space:
mode:
authorJacob Erlbeck <jerlbeck@sysmocom.de>2013-10-31 10:47:02 +0100
committerHolger Hans Peter Freyther <holger@moiji-mobile.com>2013-10-31 13:29:51 +0100
commit61bd965b04e4f00eaf4196eebb4ec6269926d551 (patch)
tree1ce74c0b496a8d387a1ee1a8a374ae6317aea9bc /openbsc/src/osmo-bsc/Makefile.am
parent6e919dbb653d4b0c209d393b2a5cf5bf8de9be62 (diff)
bsc/ussd: Send faked CM Service Accept before sending USSD
The MS do not show the USSD messages yet. This patch modifies the implementation to insert a CM Service Accept before the ussdNotify to finish the establishment of the MM connection according to 3GPP TS 04.10/3.2.1. This fix has been tested with a Blackberry phone that has shown an ussd_grace_txt after rf_locked has been set to '1'. Without this patch, that message wasn't shown. The phone has sent a CC Setup and other messages before processing the channel release message sent by the BSC, but these messages have not been forwarded to the MSC (as expected). Ticket: OW#957 Sponsored-by: On-Waves ehf
Diffstat (limited to 'openbsc/src/osmo-bsc/Makefile.am')
-rw-r--r--openbsc/src/osmo-bsc/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/openbsc/src/osmo-bsc/Makefile.am b/openbsc/src/osmo-bsc/Makefile.am
index 63972c838..9c091afa6 100644
--- a/openbsc/src/osmo-bsc/Makefile.am
+++ b/openbsc/src/osmo-bsc/Makefile.am
@@ -16,5 +16,7 @@ osmo_bsc_LDADD = $(top_builddir)/src/libbsc/libbsc.a \
$(top_builddir)/src/libcommon/libcommon.a \
$(top_builddir)/src/libctrl/libctrl.a \
$(top_builddir)/src/libcommon/libcommon.a \
- $(LIBOSMOSCCP_LIBS) $(LIBOSMOCORE_LIBS) \
- $(LIBOSMOGSM_LIBS) $(LIBOSMOVTY_LIBS) $(COVERAGE_LDFLAGS) $(LIBOSMOABIS_LIBS)
+ -ldbi -ldl $(LIBOSMOSCCP_LIBS) \
+ $(LIBSMPP34_LIBS) $(LIBOSMOCORE_LIBS) \
+ $(LIBOSMOGSM_LIBS) $(LIBOSMOVTY_LIBS) $(COVERAGE_LDFLAGS) \
+ $(LIBOSMOABIS_LIBS)