aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/src/Makefile.am
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2011-01-06 14:44:15 +0100
committerHolger Hans Peter Freyther <zecke@selfish.org>2011-01-06 14:52:50 +0100
commit913bc032b9f1b18cdcf8f15bdb663879c415c762 (patch)
tree40c5dd55db481e76d36507c669d3ac6ab627e186 /openbsc/src/Makefile.am
parent59234a3eb28ef9c560518a18c956802a63589183 (diff)
mncc: Move the cc_tx_to_mncc code into the libbsc.a
The trau_mux likes to call cc_tx_to_mncc for each received frame from the E1 link. Using a signal for each audio frame is messy as well. The best thing I could think of is to put this into the BSC to deref the pointer. The other option would be to include the gsm_data.h in the mncc.h header and have the method as inline.
Diffstat (limited to 'openbsc/src/Makefile.am')
-rw-r--r--openbsc/src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/openbsc/src/Makefile.am b/openbsc/src/Makefile.am
index c86fc26c9..290bc0696 100644
--- a/openbsc/src/Makefile.am
+++ b/openbsc/src/Makefile.am
@@ -22,7 +22,7 @@ libbsc_a_SOURCES = abis_rsl.c abis_nm.c gsm_data.c gsm_04_08_utils.c \
trau_frame.c trau_mux.c paging.c e1_config.c e1_input.c \
input/misdn.c input/ipaccess.c handover_logic.c \
talloc_ctx.c system_information.c rest_octets.c \
- bts_siemens_bs11.c bts_ipaccess_nanobts.c \
+ bts_siemens_bs11.c bts_ipaccess_nanobts.c mncc_upqueue.c \
bts_unknown.c bsc_version.c bsc_api.c bsc_vty.c meas_rep.c gsm_04_80.c
libmsc_a_SOURCES = gsm_subscriber.c db.c \