aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/include/openbsc/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2012-11-11 10:58:51 +0100
committerHarald Welte <laforge@gnumonks.org>2015-01-01 13:03:03 +0100
commitb4771a6871efb3cf12b371aedc575912984ca528 (patch)
treecfda932aa489b0ec304ceac51f2a6b123191714d /openbsc/include/openbsc/Makefile.am
parent7ff77ec713c6569715077344563ff9ab1719619c (diff)
Initial support for export + curses-visualization of measurements
This extends osmo_nitb to offer a UDP feed of real-time measurement reports, which can be used by (a variety of) external tools for visualization or other processing. We also add a small ncurses based tool (meas_vis) which shows a baragraph display of the last few mobile stations that were active, indicating their uplink/downlink receive level and quality. <WARNING> This sends non-portable structures like gsm_meas_rep over UDP and assumes the receiver has identical alignment and endianness! Before this feature is merged, it either needs to be converted to a unix domain socket (but they don't do multicast, which would be nice) or the wire format needs to change into something portable with defined alignment and encoding </WARNING>
Diffstat (limited to 'openbsc/include/openbsc/Makefile.am')
-rw-r--r--openbsc/include/openbsc/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/openbsc/include/openbsc/Makefile.am b/openbsc/include/openbsc/Makefile.am
index b55a20cd2..70365f2b3 100644
--- a/openbsc/include/openbsc/Makefile.am
+++ b/openbsc/include/openbsc/Makefile.am
@@ -15,7 +15,7 @@ noinst_HEADERS = abis_nm.h abis_rsl.h db.h gsm_04_08.h gsm_data.h \
bss.h gsm_data_shared.h ipaccess.h mncc_int.h \
arfcn_range_encode.h nat_rewrite_trie.h bsc_nat_callstats.h \
osmux.h mgcp_transcode.h rtp.h gprs_utils.h \
- gprs_gb_parse.h smpp.h
+ gprs_gb_parse.h smpp.h meas_feed.h
openbsc_HEADERS = gsm_04_08.h meas_rep.h bsc_api.h
openbscdir = $(includedir)/openbsc