aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/include/openbsc/Makefile.am
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2010-07-31 05:17:17 +0800
committerHolger Hans Peter Freyther <zecke@selfish.org>2010-07-31 05:20:31 +0800
commitc2b31ed9cda31d9432ae733e6ca112ccf38f0996 (patch)
tree3d373b72bbb38a976db4d2fc9343e3e16d07c191 /openbsc/include/openbsc/Makefile.am
parent5654c5b090dfb797320a53c1132605d8006533de (diff)
nat: Fix compilation with nat not being enabled.
common_vty.c was including bsc_nat.h which tried to get the sccp/sccp_types.h which is not required to be installed. Move all structs using/embedding SCCP structures into the bsc_nat_sccp.h and include. This should fix the compilation.
Diffstat (limited to 'openbsc/include/openbsc/Makefile.am')
-rw-r--r--openbsc/include/openbsc/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/openbsc/include/openbsc/Makefile.am b/openbsc/include/openbsc/Makefile.am
index e55a83c1e..234a47c98 100644
--- a/openbsc/include/openbsc/Makefile.am
+++ b/openbsc/include/openbsc/Makefile.am
@@ -10,7 +10,7 @@ noinst_HEADERS = abis_nm.h abis_rsl.h db.h gsm_04_08.h gsm_data.h \
crc24.h gprs_bssgp.h gprs_llc.h gprs_ns.h gprs_gmm.h \
gb_proxy.h gprs_sgsn.h gsm_04_08_gprs.h sgsn.h \
gprs_ns_frgre.h auth.h osmo_msc.h bsc_msc.h bsc_nat.h \
- osmo_bsc_rf.h osmo_bsc.h network_listen.h
+ osmo_bsc_rf.h osmo_bsc.h network_listen.h bsc_nat_sccp.h
openbsc_HEADERS = gsm_04_08.h meas_rep.h bsc_api.h
openbscdir = $(includedir)/openbsc