aboutsummaryrefslogtreecommitdiffstats
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorNeels Hofmeyr <neels@hofmeyr.de>2018-05-28 14:29:49 +0200
committerHarald Welte <laforge@gnumonks.org>2018-06-08 16:16:42 +0000
commit44fcc9f11e80cd4ae0811dc41f8201c5d95dea6b (patch)
tree91580d1ddbea6927bb77776370f72b725eed1d88 /doc/Makefile.am
parentc4bb31dcad3b0bedd6f1ad89d99ada71be55f06d (diff)
doc: charts: illustrate new plan for ts and lchans
Add lchan and timeslot FSM charts to illustrate planning of how osmo-bsc should handle lchan assignment and release. Modify assignment, handover, lchan-release charts according to the new plan. Change-Id: I18d60de5ee932c962aad0a532965a55d570bb936
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 5fe5674a8..ca0470d01 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -7,11 +7,24 @@ msc: \
$(builddir)/assignment.png \
$(builddir)/lchan-release.png \
$(builddir)/ms-channel-request.png \
+ $(builddir)/timeslot.png \
+ $(builddir)/lchan.png \
+ $(builddir)/ts-and-lchan-fsm-lifecycle.png \
+ $(builddir)/handover-inter-bsc-mo.png \
+ $(builddir)/handover-inter-bsc-mt.png \
+ $(NULL)
+
+dot: \
+ $(builddir)/timeslot-fsm.png \
+ $(builddir)/lchan-fsm.png \
$(NULL)
$(builddir)/%.png: $(srcdir)/%.msc
mscgen -T png -o $@ $<
+$(builddir)/%.png: $(srcdir)/%.dot
+ dot -Tpng $< > $@
+
.PHONY: poll
poll:
- while true; do $(MAKE) msc; sleep 1; done
+ while true; do $(MAKE) msc dot; sleep 1; done