aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <holger@moiji-mobile.com>2014-09-23 16:52:19 +0200
committerHolger Hans Peter Freyther <holger@moiji-mobile.com>2014-09-23 16:59:36 +0200
commitf97f58deb2bd7709758a102bccf7e95ca2ff3e67 (patch)
tree9567de9787eef0b3817d633149ed87c8b9fa14b4 /debian
parent493ec593f7256ea31ba7ad224f8d1c7c77c6eb77 (diff)
debian: Harden and build debug packages
Diffstat (limited to 'debian')
-rw-r--r--debian/control7
-rwxr-xr-xdebian/rules4
2 files changed, 11 insertions, 0 deletions
diff --git a/debian/control b/debian/control
index dc546bf..42d8c8b 100644
--- a/debian/control
+++ b/debian/control
@@ -24,3 +24,10 @@ Depends: ${misc:Depends}, libgtp0
Architecture: any
Section: libdevel
Description: Development files for libgtp
+
+Package: openggsn-dbg
+Section: debug
+Architecture: any
+Priority: extra
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: Debug symbols for OpenGGSN
diff --git a/debian/rules b/debian/rules
index bce9ff3..981fa51 100755
--- a/debian/rules
+++ b/debian/rules
@@ -15,6 +15,7 @@
# This has to be exported to make some magic below work.
export DH_OPTIONS
+export DEB_BUILD_HARDENING=1
CFLAGS = -Wall -g
@@ -22,3 +23,6 @@ CFLAGS = -Wall -g
dh --with autoreconf $@
override_dh_auto_clean:
+
+override_dh_strip:
+ dh_strip --dbg-package=openggsn-dbg