aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorjjako <jjako>2003-01-28 21:58:05 +0000
committerjjako <jjako>2003-01-28 21:58:05 +0000
commit52c6234c56c8b03884996dbf50c3ffd34be85566 (patch)
tree664d734b3dc313962c72e1098a1f088abff77f0d /configure.in
parentd8495fc894022056698f82082de230a6347f88f3 (diff)
New autotools files (Redhat 8)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in57
1 files changed, 41 insertions, 16 deletions
diff --git a/configure.in b/configure.in
index b57153d..eab673c 100644
--- a/configure.in
+++ b/configure.in
@@ -1,32 +1,57 @@
-dnl Process this file with autoconf to produce a configure script.
-AC_INIT(gtp/gtp.c)
+# Process this file with autoconf to produce a configure script.
+AC_INIT(openggsn, 0.52, jj@openggsn.org)
+AC_CONFIG_SRCDIR([gtp/gtp.c])
+AM_CONFIG_HEADER([config.h])
+#AC_CONFIG_HEADER([config.h])
-dnl Checks for programs.
-AC_PROG_AWK
+# Checks for programs.
AC_PROG_CC
AC_PROG_INSTALL
-AC_PROG_LN_S
+AC_PROG_AWK
+AC_PROG_CPP
+AC_PROG_CXX
+AC_PROG_RANLIB
+
+#JJAKO Check for libtool
AC_PROG_LIBTOOL
AM_PROG_LIBTOOL
-dnl Checks for libraries.
-dnl Checks for header files.
+# Checks for libraries.
+# FIXME: Replace `main' with a function in `-le':
+AC_CHECK_LIB([e], [main])
+# FIXME: Replace `main' with a function in `-lgtp':
+AC_CHECK_LIB([gtp], [main])
+# FIXME: Replace `main' with a function in `-links':
+AC_CHECK_LIB([inks], [main])
+
+# Checks for header files.
AC_HEADER_STDC
AC_HEADER_SYS_WAIT
-AC_CHECK_HEADERS(fcntl.h strings.h sys/ioctl.h sys/time.h syslog.h unistd.h)
+AC_CHECK_HEADERS([arpa/inet.h fcntl.h netdb.h netinet/in.h stdint.h stdlib.h string.h sys/ioctl.h sys/socket.h sys/time.h syslog.h unistd.h])
-dnl Checks for typedefs, structures, and compiler characteristics.
+# Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST
+AC_TYPE_MODE_T
AC_TYPE_SIZE_T
AC_HEADER_TIME
-dnl Checks for library functions.
+# Checks for library functions.
AC_PROG_GCC_TRADITIONAL
-AC_FUNC_VFORK
-AC_CHECK_FUNCS(select socket strdup strerror strtoul)
-
-AM_INIT_AUTOMAKE(OpenGGSN,0.51)
-
-AC_OUTPUT(doc/Makefile po/Makefile intl/Makefile Makefile tests/Makefile src/Makefile gtp/Makefile ggsn/Makefile sgsnemu/Makefile)
+AC_FUNC_MALLOC
+AC_FUNC_MEMCMP
+AC_CHECK_FUNCS([gethostbyname inet_ntoa memset select socket strdup strerror strtol])
+
+AM_INIT_AUTOMAKE()
+
+AC_CONFIG_FILES([Makefile
+ doc/Makefile
+ ggsn/Makefile
+ gtp/Makefile
+ intl/Makefile
+ po/Makefile
+ sgsnemu/Makefile
+ src/Makefile
+ tests/Makefile])
+AC_OUTPUT