aboutsummaryrefslogtreecommitdiffstats
path: root/src/osmo-bsc_nat/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/osmo-bsc_nat/Makefile.am')
-rw-r--r--src/osmo-bsc_nat/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/osmo-bsc_nat/Makefile.am b/src/osmo-bsc_nat/Makefile.am
new file mode 100644
index 000000000..98a343108
--- /dev/null
+++ b/src/osmo-bsc_nat/Makefile.am
@@ -0,0 +1,15 @@
+INCLUDES = $(all_includes) -I$(top_srcdir)/include -I$(top_builddir)
+AM_CFLAGS=-Wall $(LIBOSMOCORE_CFLAGS) $(LIBOSMOVTY_CFLAGS) $(LIBOSMOSCCP_CFLAGS) $(COVERAGE_CFLAGS)
+AM_LDFLAGS = $(LIBOSMOCORE_LIBS) $(LIBOSMOVTY_LIBS) $(COVERAGE_LDFLAGS)
+
+bin_PROGRAMS = osmo-bsc_nat
+
+
+osmo_bsc_nat_SOURCES = bsc_filter.c bsc_mgcp_utils.c bsc_nat.c bsc_nat_utils.c \
+ bsc_nat_vty.c bsc_sccp.c bsc_ussd.c
+osmo_bsc_nat_LDADD = $(top_builddir)/src/libcommon/libcommon.a \
+ $(top_builddir)/src/libmgcp/libmgcp.a \
+ $(top_builddir)/src/libbsc/libbsc.a \
+ $(top_builddir)/src/libabis/libabis.a \
+ $(top_builddir)/src/libtrau/libtrau.a \
+ -lrt $(LIBOSMOSCCP_LIBS)