aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/tests/sgsn/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'openbsc/tests/sgsn/Makefile.am')
-rw-r--r--openbsc/tests/sgsn/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/openbsc/tests/sgsn/Makefile.am b/openbsc/tests/sgsn/Makefile.am
index 74af15991..ce644299e 100644
--- a/openbsc/tests/sgsn/Makefile.am
+++ b/openbsc/tests/sgsn/Makefile.am
@@ -1,5 +1,8 @@
AM_CPPFLAGS = $(all_includes) -I$(top_srcdir)/include
AM_CFLAGS=-Wall -ggdb3 $(LIBOSMOCORE_CFLAGS) $(LIBOSMOGSM_CFLAGS) $(LIBCARES_CFLAGS)
+if BUILD_IU
+AM_CFLAGS += $(LIBASN1C_CFLAGS) $(LIBOSMOSIGTRAN_CFLAGS) $(LIBOSMORANAP_CFLAGS)
+endif
EXTRA_DIST = sgsn_test.ok
@@ -39,4 +42,11 @@ sgsn_test_LDADD = \
$(LIBCARES_LIBS) \
$(LIBCRYPTO_LIBS) \
-lgtp -lrt
+if BUILD_IU
+sgsn_test_LDADD += \
+ $(top_builddir)/src/libiu/libiu.a \
+ $(LIBOSMORANAP_LIBS) \
+ $(LIBOSMOSIGTRAN_LIBS) \
+ $(LIBASN1C_LIBS)
+endif