aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/tests/mm_auth/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'openbsc/tests/mm_auth/Makefile.am')
-rw-r--r--openbsc/tests/mm_auth/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/openbsc/tests/mm_auth/Makefile.am b/openbsc/tests/mm_auth/Makefile.am
new file mode 100644
index 000000000..516df0007
--- /dev/null
+++ b/openbsc/tests/mm_auth/Makefile.am
@@ -0,0 +1,21 @@
+AM_CPPFLAGS = $(all_includes) -I$(top_srcdir)/include
+AM_CFLAGS=-Wall \
+ $(LIBOSMOCORE_CFLAGS) \
+ $(LIBOSMOGSM_CFLAGS) \
+ $(LIBCRYPTO_CFLAGS)
+
+noinst_PROGRAMS = mm_auth_test
+
+EXTRA_DIST = mm_auth_test.ok
+
+mm_auth_test_SOURCES = mm_auth_test.c
+
+mm_auth_test_LDFLAGS = \
+ -Wl,--wrap=db_get_authinfo_for_subscr \
+ -Wl,--wrap=db_get_lastauthtuple_for_subscr \
+ -Wl,--wrap=db_sync_lastauthtuple_for_subscr
+
+mm_auth_test_LDADD = $(top_builddir)/src/libmsc/libmsc.a \
+ $(top_builddir)/src/libcommon/libcommon.a \
+ $(LIBOSMOCORE_LIBS) \
+ $(LIBOSMOGSM_LIBS)