aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/tests/mm_auth/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'openbsc/tests/mm_auth/Makefile.am')
-rw-r--r--openbsc/tests/mm_auth/Makefile.am41
1 files changed, 28 insertions, 13 deletions
diff --git a/openbsc/tests/mm_auth/Makefile.am b/openbsc/tests/mm_auth/Makefile.am
index 516df0007..7eb14fa49 100644
--- a/openbsc/tests/mm_auth/Makefile.am
+++ b/openbsc/tests/mm_auth/Makefile.am
@@ -1,21 +1,36 @@
-AM_CPPFLAGS = $(all_includes) -I$(top_srcdir)/include
-AM_CFLAGS=-Wall \
- $(LIBOSMOCORE_CFLAGS) \
- $(LIBOSMOGSM_CFLAGS) \
- $(LIBCRYPTO_CFLAGS)
+AM_CPPFLAGS = \
+ $(all_includes) \
+ -I$(top_srcdir)/include \
+ $(NULL)
-noinst_PROGRAMS = mm_auth_test
+AM_CFLAGS = \
+ -Wall \
+ $(LIBOSMOCORE_CFLAGS) \
+ $(LIBOSMOGSM_CFLAGS) \
+ $(LIBCRYPTO_CFLAGS) \
+ $(NULL)
-EXTRA_DIST = mm_auth_test.ok
+noinst_PROGRAMS = \
+ mm_auth_test \
+ $(NULL)
-mm_auth_test_SOURCES = mm_auth_test.c
+EXTRA_DIST = \
+ mm_auth_test.ok \
+ $(NULL)
+
+mm_auth_test_SOURCES = \
+ mm_auth_test.c \
+ $(NULL)
mm_auth_test_LDFLAGS = \
-Wl,--wrap=db_get_authinfo_for_subscr \
-Wl,--wrap=db_get_lastauthtuple_for_subscr \
- -Wl,--wrap=db_sync_lastauthtuple_for_subscr
+ -Wl,--wrap=db_sync_lastauthtuple_for_subscr \
+ $(NULL)
-mm_auth_test_LDADD = $(top_builddir)/src/libmsc/libmsc.a \
- $(top_builddir)/src/libcommon/libcommon.a \
- $(LIBOSMOCORE_LIBS) \
- $(LIBOSMOGSM_LIBS)
+mm_auth_test_LDADD = \
+ $(top_builddir)/src/libmsc/libmsc.a \
+ $(top_builddir)/src/libcommon/libcommon.a \
+ $(LIBOSMOCORE_LIBS) \
+ $(LIBOSMOGSM_LIBS) \
+ $(NULL)