aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/tests/gtphub/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'openbsc/tests/gtphub/Makefile.am')
-rw-r--r--openbsc/tests/gtphub/Makefile.am32
1 files changed, 24 insertions, 8 deletions
diff --git a/openbsc/tests/gtphub/Makefile.am b/openbsc/tests/gtphub/Makefile.am
index dcb721150..137924da2 100644
--- a/openbsc/tests/gtphub/Makefile.am
+++ b/openbsc/tests/gtphub/Makefile.am
@@ -1,24 +1,40 @@
-AM_CPPFLAGS = $(all_includes) -I$(top_srcdir)/include
-AM_CFLAGS=-Wall -ggdb3 $(LIBOSMOCORE_CFLAGS)
+AM_CPPFLAGS = \
+ $(all_includes) \
+ -I$(top_srcdir)/include \
+ $(NULL)
+
+AM_CFLAGS = \
+ -Wall \
+ -ggdb3 \
+ $(LIBOSMOCORE_CFLAGS) \
+ $(NULL)
EXTRA_DIST = \
- gtphub_test.ok
+ gtphub_test.ok \
+ $(NULL)
if HAVE_LIBGTP
if HAVE_LIBCARES
-noinst_PROGRAMS = gtphub_test
+noinst_PROGRAMS = \
+ gtphub_test \
+ $(NULL)
endif
endif
-gtphub_test_SOURCES = gtphub_test.c
+gtphub_test_SOURCES = \
+ gtphub_test.c \
+ $(NULL)
+
gtphub_test_LDFLAGS = \
-Wl,--wrap=gtphub_resolve_ggsn_addr \
-Wl,--wrap=gtphub_ares_init \
- -Wl,--wrap=gtphub_write
+ -Wl,--wrap=gtphub_write \
+ $(NULL)
gtphub_test_LDADD = \
$(top_builddir)/src/gprs/gtphub.o \
$(top_builddir)/src/gprs/gprs_utils.o \
$(LIBOSMOCORE_LIBS) \
- -lgtp -lrt
-
+ -lgtp \
+ -lrt \
+ $(NULL)