aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/tests/gtphub/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'openbsc/tests/gtphub/Makefile.am')
-rw-r--r--openbsc/tests/gtphub/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/openbsc/tests/gtphub/Makefile.am b/openbsc/tests/gtphub/Makefile.am
index ecc6d62f0..d818811d9 100644
--- a/openbsc/tests/gtphub/Makefile.am
+++ b/openbsc/tests/gtphub/Makefile.am
@@ -11,10 +11,12 @@ noinst_PROGRAMS = gtphub_test
gtphub_test_SOURCES = gtphub_test.c
gtphub_test_LDFLAGS = \
- -Wl,--wrap=gtphub_resolve_ggsn_addr
+ -Wl,--wrap=gtphub_resolve_ggsn_addr \
+ -Wl,--wrap=gtphub_ares_init
gtphub_test_LDADD = \
$(top_builddir)/src/gprs/gtphub.o \
+ $(top_builddir)/src/gprs/gprs_utils.o \
$(LIBOSMOCORE_LIBS) \
-lgtp -lrt