aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/tests/channel/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'openbsc/tests/channel/Makefile.am')
-rw-r--r--openbsc/tests/channel/Makefile.am12
1 files changed, 3 insertions, 9 deletions
diff --git a/openbsc/tests/channel/Makefile.am b/openbsc/tests/channel/Makefile.am
index 6b9f6e3cb..772965953 100644
--- a/openbsc/tests/channel/Makefile.am
+++ b/openbsc/tests/channel/Makefile.am
@@ -1,5 +1,5 @@
INCLUDES = $(all_includes) -I$(top_srcdir)/include
-AM_CFLAGS=-Wall -ggdb3
+AM_CFLAGS=-Wall -ggdb3 $(LIBOSMOCORE_CFLAGS)
noinst_PROGRAMS = channel_test
@@ -8,14 +8,8 @@ channel_test_SOURCES = channel_test.c \
$(top_srcdir)/src/gsm_subscriber_base.c \
$(top_srcdir)/src/gsm_subscriber.c \
$(top_srcdir)/src/debug.c \
- $(top_srcdir)/src/timer.c \
- $(top_srcdir)/src/select.c \
- $(top_srcdir)/src/talloc.c \
$(top_srcdir)/src/gsm_data.c \
- $(top_srcdir)/src/signal.c \
- $(top_srcdir)/src/statistics.c \
$(top_srcdir)/src/bts_ipaccess_nanobts.c \
- $(top_srcdir)/src/bts_siemens_bs11.c \
- $(top_srcdir)/src/tlv_parser.c
-channel_test_LDADD = -ldl -ldbi
+ $(top_srcdir)/src/bts_siemens_bs11.c
+channel_test_LDADD = -ldl -ldbi $(LIBOSMOCORE_LIBS)