aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/src/utils/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'openbsc/src/utils/Makefile.am')
-rw-r--r--openbsc/src/utils/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/openbsc/src/utils/Makefile.am b/openbsc/src/utils/Makefile.am
index c5b6a7add..701e9b86b 100644
--- a/openbsc/src/utils/Makefile.am
+++ b/openbsc/src/utils/Makefile.am
@@ -4,6 +4,10 @@ AM_LDFLAGS = $(COVERAGE_LDFLAGS)
bin_PROGRAMS = bs11_config isdnsync
+if BUILD_SMPP
+noinst_PROGRAMS = smpp_mirror
+endif
+
bs11_config_SOURCES = bs11_config.c
bs11_config_LDADD = $(top_builddir)/src/libcommon/libcommon.a \
$(top_builddir)/src/libbsc/libbsc.a \
@@ -11,3 +15,7 @@ bs11_config_LDADD = $(top_builddir)/src/libcommon/libcommon.a \
$(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS) $(LIBOSMOABIS_LIBS)
isdnsync_SOURCES = isdnsync.c
+
+smpp_mirror_SOURCES = smpp_mirror.c
+smpp_mirror_LDADD = $(top_builddir)/src/libcommon/libcommon.a \
+ $(LIBOSMOCORE_LIBS) $(LIBSMPP34_LIBS)