aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/src/libcommon/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'openbsc/src/libcommon/Makefile.am')
-rw-r--r--openbsc/src/libcommon/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/openbsc/src/libcommon/Makefile.am b/openbsc/src/libcommon/Makefile.am
index 6582d1ea3..0b258c08a 100644
--- a/openbsc/src/libcommon/Makefile.am
+++ b/openbsc/src/libcommon/Makefile.am
@@ -23,8 +23,25 @@ libcommon_a_SOURCES = \
debug.c \
gsm_data.c \
gsm_data_shared.c \
+ gsup_client.c \
oap_client.c \
socket.c \
talloc_ctx.c \
gsm_subscriber_base.c \
$(NULL)
+
+noinst_PROGRAMS = \
+ gsup_test_client \
+ $(NULL)
+
+gsup_test_client_SOURCES = \
+ gsup_test_client.c \
+ $(NULL)
+gsup_test_client_LDADD = \
+ libcommon.a \
+ $(LIBOSMOCORE_LIBS) \
+ $(LIBOSMOGSM_LIBS) \
+ $(LIBOSMOVTY_LIBS) \
+ $(LIBOSMOABIS_LIBS) \
+ -lrt \
+ $(NULL)