aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/src/bsc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'openbsc/src/bsc/Makefile.am')
-rw-r--r--openbsc/src/bsc/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/openbsc/src/bsc/Makefile.am b/openbsc/src/bsc/Makefile.am
new file mode 100644
index 000000000..f4e7a723a
--- /dev/null
+++ b/openbsc/src/bsc/Makefile.am
@@ -0,0 +1,12 @@
+INCLUDES = $(all_includes) -I$(top_srcdir)/include -I$(top_builddir)
+AM_CFLAGS=-Wall $(LIBOSMOCORE_CFLAGS) $(LIBOSMOVTY_CFLAGS)
+AM_LDFLAGS = $(LIBOSMOCORE_LIBS) $(LIBOSMOVTY_LIBS)
+
+bin_PROGRAMS = osmo-bsc
+
+
+osmo_bsc_SOURCES = osmo_bsc_main.c osmo_bsc_rf.c \
+ $(top_srcdir)/src/debug.c $(top_srcdir)/src/bsc_msc.c \
+ $(top_srcdir)/src/bsc_init.c
+osmo_bsc_LDADD = $(top_builddir)/src/libvty.a $(top_builddir)/src/libsccp.a \
+ $(top_builddir)/src/libmgcp.a $(top_builddir)/src/libbsc.a