aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/doc/examples/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'openbsc/doc/examples/Makefile.am')
-rw-r--r--openbsc/doc/examples/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/openbsc/doc/examples/Makefile.am b/openbsc/doc/examples/Makefile.am
new file mode 100644
index 000000000..b7eda49d6
--- /dev/null
+++ b/openbsc/doc/examples/Makefile.am
@@ -0,0 +1,16 @@
+
+CFG_FILES = find $(srcdir) -name '*.cfg*' | sed -e 's,^$(srcdir),,'
+
+dist-hook:
+ for f in $$($(CFG_FILES)); do \
+ j="$(distdir)/$$f" && \
+ mkdir -p "$$(dirname $$j)" && \
+ $(INSTALL_DATA) $(srcdir)/$$f $$j; \
+ done
+
+install-data-hook:
+ for f in $$($(CFG_FILES)); do \
+ j="$(DESTDIR)$(docdir)/examples/$$f" && \
+ mkdir -p "$$(dirname $$j)" && \
+ $(INSTALL_DATA) $(srcdir)/$$f $$j; \
+ done