aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'openbsc/debian/rules')
-rwxr-xr-xopenbsc/debian/rules18
1 files changed, 5 insertions, 13 deletions
diff --git a/openbsc/debian/rules b/openbsc/debian/rules
index 8de0ecc48..4331d02a3 100755
--- a/openbsc/debian/rules
+++ b/openbsc/debian/rules
@@ -13,19 +13,11 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
-# This has to be exported to make some magic below work.
-export DH_OPTIONS
-
-# this requires debhelper 7.0.50 or above, which lenny doesn't have yet!
-#override_dh_auto_configure:
-# dh_auto_configure -- --enable-nat --enable-osmo-bsc
+%:
+ dh --with autoreconf $@
-build: build-stamp
-build-stamp:
- dh build --before configure
+override_dh_auto_configure:
dh_auto_configure -- --enable-nat --enable-osmo-bsc
- dh build --after configure
- touch build-stamp
-%:
- dh $@
+override_dh_auto_test:
+# tests are broken...