aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'openbsc/debian/rules')
-rwxr-xr-xopenbsc/debian/rules5
1 files changed, 5 insertions, 0 deletions
diff --git a/openbsc/debian/rules b/openbsc/debian/rules
index 4331d02a3..34ef3e7d9 100755
--- a/openbsc/debian/rules
+++ b/openbsc/debian/rules
@@ -13,10 +13,15 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
+DEBIAN := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
+DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
+VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
+
%:
dh --with autoreconf $@
override_dh_auto_configure:
+ echo $(VERSION) > .tarball-version
dh_auto_configure -- --enable-nat --enable-osmo-bsc
override_dh_auto_test: