aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 2 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index ef085960d..e37a26268 100755
--- a/debian/rules
+++ b/debian/rules
@@ -10,7 +10,7 @@ VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
%:
- dh $@ --sourcedirectory=openbsc --with autoreconf
+ dh $@ --sourcedirectory=openbsc --with=systemd --with autoreconf
# This is needed for debian stable (squeeze)
override_dh_autoreconf:
@@ -25,7 +25,7 @@ override_dh_strip:
override_dh_auto_configure:
echo $(VERSION) > openbsc/.tarball-version
- dh_auto_configure --sourcedirectory=openbsc -- --enable-nat --enable-osmo-bsc --enable-smpp
+ dh_auto_configure --sourcedirectory=openbsc -- --enable-nat --enable-osmo-bsc --enable-smpp --with-systemdsystemunitdir=/lib/systemd/system
# Print test results in case of a failure
override_dh_auto_test: