aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/tests/sccp/Makefile.am
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2009-07-29 07:37:48 +0200
committerHolger Hans Peter Freyther <zecke@selfish.org>2009-11-20 13:09:15 +0100
commitac96770ad7160323e2445859e128175d28f49295 (patch)
treed8bb9b4cd00ae2a5547991fabcc0f1f18c9aa90b /openbsc/tests/sccp/Makefile.am
parentff5fa4e45595671cbaf5b319eb6b6b3451b39874 (diff)
[sccp] Implement parts of ITU SCCP for use in the A-Interface
include/sccp/sccp_types.h contain Q.713 and GSM definitions include/sccp/sccp.h is the application interface resembling the esentials of the UNIX socket interface. src/sccp.c is the actual implementation of SCCP featuring connection and UDT1 support. tests/sccp/sccp.c is testing connection creation and formating of the SCCP messages used by the A-interface. And it contains a simple fuzzing test to test the robustnes of the implementation.
Diffstat (limited to 'openbsc/tests/sccp/Makefile.am')
-rw-r--r--openbsc/tests/sccp/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/openbsc/tests/sccp/Makefile.am b/openbsc/tests/sccp/Makefile.am
new file mode 100644
index 000000000..5a275fc2b
--- /dev/null
+++ b/openbsc/tests/sccp/Makefile.am
@@ -0,0 +1,8 @@
+INCLUDES = $(all_includes) -I$(top_srcdir)/include
+AM_CFLAGS=-Wall -ggdb3
+
+noinst_PROGRAMS = sccp_test
+
+sccp_test_SOURCES = sccp_test.c
+sccp_test_LDADD = $(top_builddir)/src/libsccp.a $(top_builddir)/src/libbsc.a
+