aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/tests/mgcp/Makefile.am
diff options
context:
space:
mode:
authorNeels Hofmeyr <nhofmeyr@sysmocom.de>2016-10-18 18:38:59 +0200
committerNeels Hofmeyr <nhofmeyr@sysmocom.de>2016-11-12 16:08:22 +0100
commitc692fc5e2eb62eb86c85847c79dedb4d87ad564c (patch)
tree5460cc1d7bae6ebb573fb892a436085661f6a2c4 /openbsc/tests/mgcp/Makefile.am
parentd9e229b08871c6be76e97e7d7281a824c1bdb231 (diff)
mgcp parsing, mgcp test
Diffstat (limited to 'openbsc/tests/mgcp/Makefile.am')
-rw-r--r--openbsc/tests/mgcp/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/openbsc/tests/mgcp/Makefile.am b/openbsc/tests/mgcp/Makefile.am
index 4b18036cc..31d8a51f8 100644
--- a/openbsc/tests/mgcp/Makefile.am
+++ b/openbsc/tests/mgcp/Makefile.am
@@ -22,10 +22,12 @@ AM_LDFLAGS = \
EXTRA_DIST = \
mgcp_test.ok \
mgcp_transcoding_test.ok \
+ mgcpgw_client_test.ok \
$(NULL)
noinst_PROGRAMS = \
mgcp_test \
+ mgcpgw_client_test \
$(NULL)
if BUILD_MGCP_TRANSCODING
noinst_PROGRAMS += \
@@ -70,3 +72,21 @@ mgcp_transcoding_test_LDADD = \
-lrt \
-lm \
$(NULL)
+
+mgcpgw_client_test_SOURCES = \
+ mgcpgw_client_test.c \
+ $(NULL)
+
+mgcpgw_client_test_LDADD = \
+ $(top_builddir)/src/libbsc/libbsc.a \
+ $(top_builddir)/src/libmgcp/libmgcp.a \
+ $(top_builddir)/src/libcommon/libcommon.a \
+ $(LIBOSMOCORE_LIBS) \
+ $(LIBOSMOGSM_LIBS) \
+ $(LIBOSMOSCCP_LIBS) \
+ $(LIBOSMOVTY_LIBS) \
+ $(LIBRARY_DL) \
+ $(LIBOSMONETIF_LIBS) \
+ -lrt \
+ -lm \
+ $(NULL)