aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/tests/mgcp/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2011-03-04 13:18:30 +0100
committerHarald Welte <laforge@gnumonks.org>2011-03-04 13:23:09 +0100
commit89579b4317a7f7ab6ee706399bee4b8f25a12c3a (patch)
tree8e66e64f14e582cd29f6b78023528297b71548ba /openbsc/tests/mgcp/Makefile.am
parent5a6b68f4169c0ef55dca02a9644ee8f3bbc97e60 (diff)
prefix sub-directories containing libraries with 'lib'
... and make sure tests work again after restructuring
Diffstat (limited to 'openbsc/tests/mgcp/Makefile.am')
-rw-r--r--openbsc/tests/mgcp/Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/openbsc/tests/mgcp/Makefile.am b/openbsc/tests/mgcp/Makefile.am
index fdbe56549..472368cb3 100644
--- a/openbsc/tests/mgcp/Makefile.am
+++ b/openbsc/tests/mgcp/Makefile.am
@@ -4,7 +4,9 @@ AM_LDFLAGS = $(COVERAGE_LDFLAGS)
noinst_PROGRAMS = mgcp_test
-mgcp_test_SOURCES = mgcp_test.c \
- $(top_srcdir)/src/mgcp/mgcp_protocol.c \
- $(top_srcdir)/src/mgcp/mgcp_network.c
-mgcp_test_LDADD = $(top_builddir)/src/libbsc.a $(LIBOSMOCORE_LIBS) -lrt $(LIBOSMOSCCP_LIBS) $(LIBOSMOVTY_LIBS)
+mgcp_test_SOURCES = mgcp_test.c
+
+mgcp_test_LDADD = $(top_builddir)/src/libbsc/libbsc.a \
+ $(top_builddir)/src/libmgcp/libmgcp.a \
+ $(top_builddir)/src/libcommon/libcommon.a \
+ $(LIBOSMOCORE_LIBS) -lrt $(LIBOSMOSCCP_LIBS) $(LIBOSMOVTY_LIBS)