aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/tests/Makefile.am
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2011-06-23 17:53:27 -0400
committerHolger Hans Peter Freyther <zecke@selfish.org>2012-01-06 18:52:05 +0100
commitfaf1f64a2d0a54d37616a8bec8691346ab792cde (patch)
treecf9f5052348eae7207bceeb9803967686ca3e692 /openbsc/tests/Makefile.am
parent26d0fe3c89042ed4008903dbe12c5110d8f9fc48 (diff)
gprs: Honor GSM 04.64 8.4.2 Receipt of unacknowledged information
GSM 04.64 8.4.2 asks to ignore UI frames if the DLCI is not known, or if the "(V(UR)- 32) <= N(U) < V(UR)". E.g. if we want to have V(UR) == 511 and this frame is dropped, we would ignore N(U)'s 0 to 510. Calculate the delta. The code is based on Jonathan Santos's "LLC UI window" fix but the issue was discovered independly.
Diffstat (limited to 'openbsc/tests/Makefile.am')
-rw-r--r--openbsc/tests/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/openbsc/tests/Makefile.am b/openbsc/tests/Makefile.am
index 64667c9ad..73e8b89e6 100644
--- a/openbsc/tests/Makefile.am
+++ b/openbsc/tests/Makefile.am
@@ -1,4 +1,4 @@
-SUBDIRS = debug gsm0408 db channel mgcp
+SUBDIRS = debug gsm0408 db channel mgcp gprs
if BUILD_NAT
SUBDIRS += bsc-nat