aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/tests/Makefile.am
diff options
context:
space:
mode:
authorKaterina Barone-Adesi <kat.obsc@gmail.com>2013-04-05 17:36:09 +0200
committerHolger Hans Peter Freyther <zecke@selfish.org>2013-06-24 13:22:34 +0200
commite0aee7aaa964df27fdf6c451ea43af66c6d97b43 (patch)
tree32fb57f4c504b2c4f896c155e202961e66d2771e /openbsc/tests/Makefile.am
parentcc6b2d2fa30ad628833bf764caa8fdbac5aa1213 (diff)
Introduced support for external python tests
The test scripts warn about missing documentation, untested configs, check common errors, and stub out testing individual VTY commands. The scripts have been moved to the another osmocom repository, python/osmo-python-tests The features were requested by zecke.
Diffstat (limited to 'openbsc/tests/Makefile.am')
-rw-r--r--openbsc/tests/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/openbsc/tests/Makefile.am b/openbsc/tests/Makefile.am
index c5e0f1fd3..2944ca373 100644
--- a/openbsc/tests/Makefile.am
+++ b/openbsc/tests/Makefile.am
@@ -27,8 +27,19 @@ EXTRA_DIST = testsuite.at $(srcdir)/package.m4 $(TESTSUITE)
TESTSUITE = $(srcdir)/testsuite
DISTCLEANFILES = atconfig
+if ENABLE_VTY_TESTS
+python-tests: $(BUILT_SOURCES)
+ osmotestvty.py -p $(abs_top_srcdir) -w $(abs_top_builddir) -v
+ osmotestconfig.py -p $(abs_top_srcdir) -w $(abs_top_builddir) -v
+ rm -f $(top_builddir)/hlr.sqlite3
+else
+python-tests: $(BUILT_SOURCES)
+ echo "Not running python-based tests (determined at configure-time)"
+endif
+
check-local: atconfig $(TESTSUITE)
$(SHELL) '$(TESTSUITE)' $(TESTSUITEFLAGS)
+ $(MAKE) $(AM_MAKEFLAGS) python-tests
installcheck-local: atconfig $(TESTSUITE)
$(SHELL) '$(TESTSUITE)' AUTOTEST_PATH='$(bindir)' \