aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/tests/Makefile.am
diff options
context:
space:
mode:
authorJacob Erlbeck <jerlbeck@sysmocom.de>2013-09-17 13:59:29 +0200
committerHolger Hans Peter Freyther <holger@moiji-mobile.com>2013-09-19 10:57:13 +0200
commit946d1415c2d51eca7e64e7deffd0b247c0a8b8c7 (patch)
tree0f24c2a2b561817ce69b316d349c3ea9b5b0bde0 /openbsc/tests/Makefile.am
parent6792059d50785d9218ae7941bbdd307ac029ef85 (diff)
bsc/mminfo: Patch timezone and DST in MM Info messages
This adds in-place patching of the time information in the MM INFORMATION message. The timezone in the 'Local time zone' and the 'Universal time and local time zone' information elements and the offset in the 'Network Daylight Saving Time' information element are optionally set. The new values are determined by the 'timezone' vty command in the config_net_bts node. That command is extended by an optional DST offset parameter. Tests are provided for the vty part and for the plain bsc_scan_msc_msg() function. Sponsored-by: On-Waves ehf Ticket: OW#978
Diffstat (limited to 'openbsc/tests/Makefile.am')
-rw-r--r--openbsc/tests/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/openbsc/tests/Makefile.am b/openbsc/tests/Makefile.am
index f2dc057fa..ed21fc332 100644
--- a/openbsc/tests/Makefile.am
+++ b/openbsc/tests/Makefile.am
@@ -4,6 +4,10 @@ if BUILD_NAT
SUBDIRS += bsc-nat bsc-nat-trie
endif
+if BUILD_BSC
+SUBDIRS += bsc
+endif
+
if BUILD_SMPP
SUBDIRS += smpp
endif