aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/tests/Makefile.am
diff options
context:
space:
mode:
authorNeels Hofmeyr <nhofmeyr@sysmocom.de>2016-03-30 11:22:24 +0200
committerHarald Welte <laforge@gnumonks.org>2016-03-31 11:56:00 +0200
commit37984bdb1b507446421e5aa6131ccdf117dd269f (patch)
treee7dea62884366f31181d35f85f9d15b3c5871114 /openbsc/tests/Makefile.am
parent56ea30ff3f9f98a4903d060196b185ce124d7eaa (diff)
Add MM Auth test; add auth_action_str() function
Add basic MM Authentication test setup, with fake DB access and RAND_bytes(). So far implement simple tests for IO error during DB access and missing auth entry. To print the auth action during tests, add struct auth_action_names and auth_action_str() inline function in auth.[hc].
Diffstat (limited to 'openbsc/tests/Makefile.am')
-rw-r--r--openbsc/tests/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/openbsc/tests/Makefile.am b/openbsc/tests/Makefile.am
index 04b8e345f..09298a35c 100644
--- a/openbsc/tests/Makefile.am
+++ b/openbsc/tests/Makefile.am
@@ -1,4 +1,4 @@
-SUBDIRS = gsm0408 db channel mgcp gprs abis gbproxy trau subscr
+SUBDIRS = gsm0408 db channel mgcp gprs abis gbproxy trau subscr mm_auth
if BUILD_NAT
SUBDIRS += bsc-nat bsc-nat-trie