aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/tests/Makefile.am
diff options
context:
space:
mode:
authorPau Espin Pedrol <pespin@sysmocom.de>2019-05-03 11:36:13 +0200
committerPau Espin Pedrol <pespin@sysmocom.de>2019-05-03 12:15:38 +0200
commit22a569f2ae7defc4eae62f0b1b6d790e412d9dc7 (patch)
tree4bec7d108f31c16f9db9fac57b7aa58ac01b4a99 /openbsc/tests/Makefile.am
parent133de7d87440e9a459abef0594a5d08006ff2ed6 (diff)
tests: Fix selection of python version
According to documentation (and personal experience), AM_PATH_PYTHON selects the highest version of python, no matter if major version is different, which means if both python2 and 3 are available, 3 will be chosen an PYTHON will point to "/.../python" which is python3. Apparently, the macro cannot be easily used to pick highest python2 version. chosen an PYTHON will point to "/.../python" which is python3. Apparently, the macro cannot be easily used to pick highest python2 version. As {vty,ctrl}_test_runner.py require python2 and are incompatible with python3, let's instead rely on the system having a "python2" binary available, which is the case in most distros. cherry-picked from: osmo-bsc.git 7e78681f0f740bd68ed5255b506a1efa08a231b1. Change-Id: Icc147c8457116ad551d166313f3a79e1c2107a22
Diffstat (limited to 'openbsc/tests/Makefile.am')
-rw-r--r--openbsc/tests/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/openbsc/tests/Makefile.am b/openbsc/tests/Makefile.am
index 7208a2fe0..a62451e95 100644
--- a/openbsc/tests/Makefile.am
+++ b/openbsc/tests/Makefile.am
@@ -64,10 +64,10 @@ if ENABLE_EXT_TESTS
python-tests: $(BUILT_SOURCES)
osmotestvty.py -p $(abs_top_srcdir) -w $(abs_top_builddir) -v
osmotestconfig.py -p $(abs_top_srcdir) -w $(abs_top_builddir) -v
- $(PYTHON) $(srcdir)/vty_test_runner.py -w $(abs_top_builddir) -v
- $(PYTHON) $(srcdir)/ctrl_test_runner.py -w $(abs_top_builddir) -v
+ $(srcdir)/vty_test_runner.py -w $(abs_top_builddir) -v
+ $(srcdir)/ctrl_test_runner.py -w $(abs_top_builddir) -v
if BUILD_SMPP
- $(PYTHON) $(srcdir)/smpp_test_runner.py -w $(abs_top_builddir) -v
+ $(srcdir)/smpp_test_runner.py -w $(abs_top_builddir) -v
endif
rm -f $(top_builddir)/hlr.sqlite3
else