aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/tests/Makefile.am
diff options
context:
space:
mode:
authorJacob Erlbeck <jerlbeck@sysmocom.de>2013-09-16 11:20:28 +0200
committerHolger Hans Peter Freyther <holger@moiji-mobile.com>2013-09-16 14:03:43 +0200
commit0760a83910a487e0bdd4e958829616fd491d95ba (patch)
tree45997bb518ee3e7e67b8bf7f105832d8ecd9cff3 /openbsc/tests/Makefile.am
parentcd40fb4dea46cc82acf94f1e671aba2f3f5997cf (diff)
ctrl: Add test script for the BSC control interface
This script is similar to vty_test_runner.py but tests the control interface instead. It currently tests some error cases, BTS status queries, and setting/clearing rf_locked.
Diffstat (limited to 'openbsc/tests/Makefile.am')
-rw-r--r--openbsc/tests/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/openbsc/tests/Makefile.am b/openbsc/tests/Makefile.am
index 0597c14d0..f2dc057fa 100644
--- a/openbsc/tests/Makefile.am
+++ b/openbsc/tests/Makefile.am
@@ -27,7 +27,7 @@ $(srcdir)/package.m4: $(top_srcdir)/configure.ac
echo ' [$(PACKAGE_URL)])'; \
} >'$(srcdir)/package.m4'
-EXTRA_DIST = testsuite.at $(srcdir)/package.m4 $(TESTSUITE) vty_test_runner.py
+EXTRA_DIST = testsuite.at $(srcdir)/package.m4 $(TESTSUITE) vty_test_runner.py ctrl_test_runner.py
TESTSUITE = $(srcdir)/testsuite
DISTCLEANFILES = atconfig
@@ -36,6 +36,7 @@ python-tests: $(BUILT_SOURCES)
osmotestvty.py -p $(abs_top_srcdir) -w $(abs_top_builddir) -v
osmotestconfig.py -p $(abs_top_srcdir) -w $(abs_top_builddir) -v
$(PYTHON) $(srcdir)/vty_test_runner.py -w $(abs_top_builddir) -v
+ $(PYTHON) $(srcdir)/ctrl_test_runner.py -w $(abs_top_builddir) -v
rm -f $(top_builddir)/hlr.sqlite3
else
python-tests: $(BUILT_SOURCES)