aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/tests/Makefile.am
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <holger@moiji-mobile.com>2013-07-13 17:09:56 +0200
committerHolger Hans Peter Freyther <holger@moiji-mobile.com>2013-07-27 20:03:10 +0200
commita7328a5642566bf7b07c6d0e58dfe5da018873a5 (patch)
tree7242bc7481b70b956a7e7b373b4d285226afe2a3 /openbsc/tests/Makefile.am
parent5ecbc93656edf49c8042b269299e31e157763511 (diff)
smpp: Move the coding/mode detection into a utils file
Make sure to not ever have issues with this code again, move the utility code to a new file and create a basic testcase. The method currently has 100% line and branch coverage. My initial patched missed the smpp_utils.c file and I re-did the copying (and verifying the branch coverage)
Diffstat (limited to 'openbsc/tests/Makefile.am')
-rw-r--r--openbsc/tests/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/openbsc/tests/Makefile.am b/openbsc/tests/Makefile.am
index c0e48df19..c9afeedd4 100644
--- a/openbsc/tests/Makefile.am
+++ b/openbsc/tests/Makefile.am
@@ -4,6 +4,10 @@ if BUILD_NAT
SUBDIRS += bsc-nat
endif
+if BUILD_SMPP
+SUBDIRS += smpp
+endif
+
# The `:;' works around a Bash 3.2 bug when the output is not writeable.
$(srcdir)/package.m4: $(top_srcdir)/configure.ac