aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/src/utils/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2012-11-15 12:29:15 +0100
committerHarald Welte <laforge@gnumonks.org>2015-01-01 13:03:03 +0100
commitdfbc42c261b438271487822f0ccd687fda84129f (patch)
tree6422677a479ede272b48cb4b69a36ec610ddc175 /openbsc/src/utils/Makefile.am
parentdc9b4e9ebf64e0227c85ebbb870254a1de6058d4 (diff)
meas_feed: add osmo-meas-udp2db for realtime feed into database
This tool can save the meas_feed messages from UDP port 8888 directly to a sqlite3 database for further analysis.
Diffstat (limited to 'openbsc/src/utils/Makefile.am')
-rw-r--r--openbsc/src/utils/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/openbsc/src/utils/Makefile.am b/openbsc/src/utils/Makefile.am
index 3fd7e100c..30f787fa5 100644
--- a/openbsc/src/utils/Makefile.am
+++ b/openbsc/src/utils/Makefile.am
@@ -5,9 +5,9 @@ AM_LDFLAGS = $(COVERAGE_LDFLAGS)
noinst_HEADERS = meas_db.h
if HAVE_LIBCDK
-bin_PROGRAMS = bs11_config isdnsync osmo-meas-pcap2db meas_vis
+bin_PROGRAMS = bs11_config isdnsync osmo-meas-pcap2db osmo-meas-udp2db meas_vis
else
-bin_PROGRAMS = bs11_config isdnsync osmo-meas-pcap2db
+bin_PROGRAMS = bs11_config isdnsync osmo-meas-pcap2db osmo-meas-udp2db
endif
if BUILD_SMPP
@@ -33,3 +33,7 @@ meas_vis_CFLAGS = $(LIBOSMOCORE_CFLAGS) $(LIBOSMOGSM_CFLAGS)
osmo_meas_pcap2db_SOURCES = meas_pcap2db.c meas_db.c
osmo_meas_pcap2db_LDADD = $(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS) -lpcap -lsqlite3
osmo_meas_pcap2db_CFLAGS = $(LIBOSMOCORE_CFLAGS) $(LIBOSMOGSM_CFLAGS)
+
+osmo_meas_udp2db_SOURCES = meas_udp2db.c meas_db.c
+osmo_meas_udp2db_LDADD = $(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS) -lsqlite3
+osmo_meas_udp2db_CFLAGS = $(LIBOSMOCORE_CFLAGS) $(LIBOSMOGSM_CFLAGS)