aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/src/utils/Makefile.am
diff options
context:
space:
mode:
authorAlexander Chemeris <Alexander.Chemeris@gmail.com>2015-06-10 18:55:28 -0400
committerAlexander Chemeris <Alexander.Chemeris@gmail.com>2017-02-25 05:23:22 +0000
commitc634063ea37875f38a31c5ff643a5fed43d7cafa (patch)
tree3531ef6ad341a86152d189bff5ea3be82395e7e5 /openbsc/src/utils/Makefile.am
parent0e5d807297f4fd1222fafece864519c70f7965a3 (diff)
utils: 'meas_json' utility to convert measurement feed into a JSON feed.
Diffstat (limited to 'openbsc/src/utils/Makefile.am')
-rw-r--r--openbsc/src/utils/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/openbsc/src/utils/Makefile.am b/openbsc/src/utils/Makefile.am
index 6fe840c6d..ab4f3ced6 100644
--- a/openbsc/src/utils/Makefile.am
+++ b/openbsc/src/utils/Makefile.am
@@ -25,6 +25,7 @@ noinst_HEADERS = \
bin_PROGRAMS = \
bs11_config \
isdnsync \
+ meas_json \
$(NULL)
if HAVE_SQLITE3
bin_PROGRAMS += \
@@ -121,3 +122,19 @@ osmo_meas_udp2db_CFLAGS = \
$(LIBOSMOCORE_CFLAGS) \
$(LIBOSMOGSM_CFLAGS) \
$(NULL)
+
+meas_json_SOURCES = \
+ meas_json.c \
+ $(NULL)
+
+meas_json_LDADD = \
+ $(top_builddir)/src/libcommon/libcommon.a \
+ $(LIBOSMOCORE_LIBS) \
+ $(LIBOSMOGSM_LIBS) \
+ $(NULL)
+
+meas_json_CFLAGS = \
+ $(LIBOSMOCORE_CFLAGS) \
+ $(LIBOSMOGSM_CFLAGS) \
+ $(NULL)
+