aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/src/utils/Makefile.am
diff options
context:
space:
mode:
authorNeels Hofmeyr <nhofmeyr@sysmocom.de>2016-03-04 14:37:31 +0100
committerNeels Hofmeyr <nhofmeyr@sysmocom.de>2016-03-04 14:57:09 +0100
commita4198d192234a8180a89be8b91e867a1cbc1f512 (patch)
treed75d1d9d2fb9e50b94927a85161eab59489e1f86 /openbsc/src/utils/Makefile.am
parent544a203f677d0f060d2d1bd31f72f9ae450e138f (diff)
create libxsc and move some code, never link libbsc and libmsc
libbsc and libmsc have conflicting definitions of gsm_subscriber_connection and do no longer belong together anyway. Create libxsc, meaning 'lib[bm]sc', to hold all code used by both libmsc and libbsc, and make sure gsm_subscriber_connection isn't used there. In various binaries and tests, do not link libbsc and libmsc. (Note: this commit was reshaped out of a large wip chunk, it may not compile properly without the subsequent commits)
Diffstat (limited to 'openbsc/src/utils/Makefile.am')
-rw-r--r--openbsc/src/utils/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/openbsc/src/utils/Makefile.am b/openbsc/src/utils/Makefile.am
index 4521130be..486a878b8 100644
--- a/openbsc/src/utils/Makefile.am
+++ b/openbsc/src/utils/Makefile.am
@@ -1,5 +1,5 @@
AM_CPPFLAGS = $(all_includes) -I$(top_srcdir)/include -I$(top_builddir)
-AM_CFLAGS=-Wall $(LIBOSMOCORE_CFLAGS) $(LIBOSMOGSM_CFLAGS) $(LIBOSMOVTY_CFLAGS) $(LIBOSMOABIS_CFLAGS) $(COVERAGE_CFLAGS) $(SQLITE3_CFLAGS) \
+AM_CFLAGS=-Wall $(LIBOSMOCORE_CFLAGS) $(LIBOSMOGSM_CFLAGS) $(LIBOSMOABIS_CFLAGS) $(COVERAGE_CFLAGS) $(SQLITE3_CFLAGS) \
$(LIBSMPP34_CFLAGS)
AM_LDFLAGS = $(COVERAGE_LDFLAGS)
@@ -21,6 +21,7 @@ bs11_config_SOURCES = bs11_config.c
bs11_config_LDADD = $(top_builddir)/src/libbsc/libbsc.a \
$(top_builddir)/src/libtrau/libtrau.a \
$(top_builddir)/src/libcommon/libcommon.a \
+ $(top_builddir)/src/libxsc/libxsc.a \
$(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS) $(LIBOSMOABIS_LIBS)
isdnsync_SOURCES = isdnsync.c