aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/src/osmo-bsc_mgcp/Makefile.am
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <holger@moiji-mobile.com>2015-07-02 09:51:31 +0200
committerHolger Hans Peter Freyther <holger@moiji-mobile.com>2015-07-02 09:51:31 +0200
commitb69518f3834b60901ab5750b6ce3b623d9479c1e (patch)
treea6954e4ec04db4c001ab930e15344779fa2208ac /openbsc/src/osmo-bsc_mgcp/Makefile.am
parent58ec15c4edd14914479f2c4a6a885a6435dc81fe (diff)
configure: Do not link all applications against libgsm
Use the same trick as done by the dlopen check to not have everyone link against the library.
Diffstat (limited to 'openbsc/src/osmo-bsc_mgcp/Makefile.am')
-rw-r--r--openbsc/src/osmo-bsc_mgcp/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/openbsc/src/osmo-bsc_mgcp/Makefile.am b/openbsc/src/osmo-bsc_mgcp/Makefile.am
index c62131b53..949cb6401 100644
--- a/openbsc/src/osmo-bsc_mgcp/Makefile.am
+++ b/openbsc/src/osmo-bsc_mgcp/Makefile.am
@@ -10,4 +10,5 @@ osmo_bsc_mgcp_SOURCES = mgcp_main.c
osmo_bsc_mgcp_LDADD = $(top_builddir)/src/libcommon/libcommon.a \
$(top_builddir)/src/libmgcp/libmgcp.a -lrt \
$(LIBOSMOVTY_LIBS) $(LIBOSMOCORE_LIBS) \
- $(LIBOSMONETIF_LIBS) $(LIBBCG729_LIBS)
+ $(LIBOSMONETIF_LIBS) $(LIBBCG729_LIBS) \
+ $(LIBRARY_GSM)