aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/src/libmsc/Makefile.am
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <holger@moiji-mobile.com>2013-07-13 17:09:56 +0200
committerHolger Hans Peter Freyther <holger@moiji-mobile.com>2013-07-27 20:03:10 +0200
commita7328a5642566bf7b07c6d0e58dfe5da018873a5 (patch)
tree7242bc7481b70b956a7e7b373b4d285226afe2a3 /openbsc/src/libmsc/Makefile.am
parent5ecbc93656edf49c8042b269299e31e157763511 (diff)
smpp: Move the coding/mode detection into a utils file
Make sure to not ever have issues with this code again, move the utility code to a new file and create a basic testcase. The method currently has 100% line and branch coverage. My initial patched missed the smpp_utils.c file and I re-did the copying (and verifying the branch coverage)
Diffstat (limited to 'openbsc/src/libmsc/Makefile.am')
-rw-r--r--openbsc/src/libmsc/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/openbsc/src/libmsc/Makefile.am b/openbsc/src/libmsc/Makefile.am
index 7faee430a..c36ba926b 100644
--- a/openbsc/src/libmsc/Makefile.am
+++ b/openbsc/src/libmsc/Makefile.am
@@ -19,5 +19,5 @@ libmsc_a_SOURCES = auth.c \
osmo_msc.c
if BUILD_SMPP
-libmsc_a_SOURCES += smpp_smsc.c smpp_openbsc.c smpp_vty.c
+libmsc_a_SOURCES += smpp_smsc.c smpp_openbsc.c smpp_vty.c smpp_utils.c
endif