aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/src/libgb/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2011-03-04 13:18:30 +0100
committerHarald Welte <laforge@gnumonks.org>2011-03-04 13:23:09 +0100
commit89579b4317a7f7ab6ee706399bee4b8f25a12c3a (patch)
tree8e66e64f14e582cd29f6b78023528297b71548ba /openbsc/src/libgb/Makefile.am
parent5a6b68f4169c0ef55dca02a9644ee8f3bbc97e60 (diff)
prefix sub-directories containing libraries with 'lib'
... and make sure tests work again after restructuring
Diffstat (limited to 'openbsc/src/libgb/Makefile.am')
-rw-r--r--openbsc/src/libgb/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/openbsc/src/libgb/Makefile.am b/openbsc/src/libgb/Makefile.am
new file mode 100644
index 000000000..b48b17791
--- /dev/null
+++ b/openbsc/src/libgb/Makefile.am
@@ -0,0 +1,9 @@
+INCLUDES = $(all_includes) -I$(top_srcdir)/include -I$(top_builddir)
+AM_CFLAGS=-Wall -fno-strict-aliasing $(LIBOSMOCORE_CFLAGS) $(LIBOSMOVTY_CFLAGS) $(COVERAGE_CFLAGS)
+AM_LDFLAGS = $(LIBOSMOCORE_LIBS) $(LIBOSMOVTY_LIBS) $(COVERAGE_LDFLAGS)
+
+noinst_LIBRARIES = libgb.a
+
+libgb_a_SOURCES = gprs_ns.c gprs_ns_frgre.c gprs_ns_vty.c \
+ gprs_bssgp.c gprs_bssgp_util.c gprs_bssgp_vty.c
+#gprs_llc.c gprs_llc_vty.c crc24.c