aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/src/libbsc/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2011-03-04 13:18:30 +0100
committerHarald Welte <laforge@gnumonks.org>2011-03-04 13:23:09 +0100
commit89579b4317a7f7ab6ee706399bee4b8f25a12c3a (patch)
tree8e66e64f14e582cd29f6b78023528297b71548ba /openbsc/src/libbsc/Makefile.am
parent5a6b68f4169c0ef55dca02a9644ee8f3bbc97e60 (diff)
prefix sub-directories containing libraries with 'lib'
... and make sure tests work again after restructuring
Diffstat (limited to 'openbsc/src/libbsc/Makefile.am')
-rw-r--r--openbsc/src/libbsc/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/openbsc/src/libbsc/Makefile.am b/openbsc/src/libbsc/Makefile.am
new file mode 100644
index 000000000..91be7fa62
--- /dev/null
+++ b/openbsc/src/libbsc/Makefile.am
@@ -0,0 +1,21 @@
+INCLUDES = $(all_includes) -I$(top_srcdir)/include -I$(top_builddir)
+AM_CFLAGS=-Wall $(LIBOSMOCORE_CFLAGS) $(LIBOSMOVTY_CFLAGS) $(COVERAGE_CFLAGS)
+AM_LDFLAGS = $(LIBOSMOCORE_LIBS) $(COVERAGE_LDFLAGS)
+
+noinst_LIBRARIES = libbsc.a
+
+libbsc_a_SOURCES = abis_nm.c abis_nm_vty.c \
+ abis_om2000.c abis_om2000_vty.c \
+ abis_rsl.c bsc_rll.c \
+ paging.c \
+ bts_ericsson_rbs2000.c bts_ipaccess_nanobts.c bts_siemens_bs11.c bts_unknown.c \
+ chan_alloc.c \
+ gsm_subscriber_base.c \
+ handover_decision.c handover_logic.c meas_rep.c \
+ rest_octets.c system_information.c \
+ e1_config.c \
+ transaction.c \
+ bsc_api.c bsc_msc.c bsc_vty.c \
+ gsm_04_08_utils.c \
+ bsc_init.c
+