aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/src/gprs/Makefile.am
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2010-05-04 14:34:04 +0800
committerHolger Hans Peter Freyther <zecke@selfish.org>2010-05-04 14:36:07 +0800
commitc6ec0406c810d265fd2db70b115458dc184bf5e5 (patch)
treef82423335a0d32db5d8d02b55237c6640e066a0a /openbsc/src/gprs/Makefile.am
parent5d6e378c3591d42a52873df059818129d3880dae (diff)
misc: Use $(top_srcdir) for source, $(top_builddir) for libs
We should not use ../ for adding sources or libraries as the user might have a srcdir != builddir setup.
Diffstat (limited to 'openbsc/src/gprs/Makefile.am')
-rw-r--r--openbsc/src/gprs/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/openbsc/src/gprs/Makefile.am b/openbsc/src/gprs/Makefile.am
index ac177f7fd..2b4292398 100644
--- a/openbsc/src/gprs/Makefile.am
+++ b/openbsc/src/gprs/Makefile.am
@@ -9,9 +9,9 @@ libsgsn_a_SOURCES = gprs_ns.c gprs_bssgp.c gprs_llc.c gsm_04_08_gprs.c \
crc24.c gprs_sgsn.c
osmo_gbproxy_SOURCES = gb_proxy.c gb_proxy_main.c gb_proxy_vty.c \
- gprs_ns.c ../socket.c ../debug.c
-osmo_gbproxy_LDADD = ../libvty.a
+ gprs_ns.c $(top_srcdir)/src/socket.c $(top_srcdir)/src/debug.c
+osmo_gbproxy_LDADD = $(top_builddir)/src/libvty.a
osmo_sgsn_SOURCES = sgsn_main.c sgsn_vty.c \
- ../socket.c ../debug.c
-osmo_sgsn_LDADD = ../libvty.a libsgsn.a
+ $(top_srcdir)/src/socket.c $(top_srcdir)/src/debug.c
+osmo_sgsn_LDADD = $(top_builddir)/src/libvty.a libsgsn.a