aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/src/gprs/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2016-05-06 23:27:38 +0200
committerHarald Welte <laforge@gnumonks.org>2016-12-13 14:54:01 +0000
commit4f8e34b226aeae221119c1d5ea659c3f087132aa (patch)
tree256040044d8cd689cbbdcc804173081e346b86bf /openbsc/src/gprs/Makefile.am
parent08586c68dba6c2ae0fb19e2c6e5a1269c7bf4a7c (diff)
add gsup_test_client program
Diffstat (limited to 'openbsc/src/gprs/Makefile.am')
-rw-r--r--openbsc/src/gprs/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/openbsc/src/gprs/Makefile.am b/openbsc/src/gprs/Makefile.am
index d228b397a..a827b77a1 100644
--- a/openbsc/src/gprs/Makefile.am
+++ b/openbsc/src/gprs/Makefile.am
@@ -37,6 +37,7 @@ OSMO_LIBS = \
$(NULL)
bin_PROGRAMS = \
+ gsup_test_client \
osmo-gbproxy \
$(NULL)
if HAVE_LIBGTP
@@ -133,3 +134,16 @@ osmo_gtphub_LDADD = \
$(LIBGTP_LIBS) \
-lrt \
$(NULL)
+
+gsup_test_client_SOURCES = \
+ gprs_gsup_client.c \
+ gsup_test_client.c \
+ oap.c \
+ $(NULL)
+gsup_test_client_LDADD = \
+ $(LIBOSMOCORE_LIBS) \
+ $(LIBOSMOGSM_LIBS) \
+ $(LIBOSMOVTY_LIBS) \
+ $(LIBOSMOABIS_LIBS) \
+ -lrt \
+ $(NULL)